INSTALACIÓN DE MOODLE

Requerimientos

Moodle está desarrollado principalmente en GNU/Linux usando Apache, MySQL y PHP (también conocida como plataforma LAMP). Si tiene dudas, esta es la combinación más segura y más común. Existen otras opciones, pues Moodle es (generalmente) compatible con PostgreSQL.

Los requerimientos básicos de Moodle son los siguientes:

Hardware

  • Espacio de disco: 160 MB ibres (mínimo) más cuanto baste para almacenar sus materiales. 5GB es probablemente un mínimo realista.
  • Respaldos: Al menos la misma cantidad que arriba y preferentemente en una localización remota, para mantener respaldos ("copias de seguridad" en España) de su sitio.
  • Memoria: 256 MB (mínimo), 1GB o más es fuertemente recomendado. La regla usual es que Moodle puede soportar de 10 a 2o usuarios concurrentes por cada GB de RAM, pero esto variará dependiendo de su combinación específica de hardware y software y el tipo de uso que les de. Concurrente realmente significa procesos de servidor web en memoria al mismo tiempo (por ejemplo: usuarios interactuando con el sistema dentro de una ventana de unos pocos segundos). NO significa personas 'dentro del sitio'.

Software

  • Un sistema operativo (¡!). Cualquiera que corra el siguiente software, aunque la elección muy probablemente dependerá del desempeño que necesite y las habilidades que tenga disponibles. Linux y Windows son las elecciones más comunes y para las que existe buen soporte disponible. Si Usted puede elegir libremente, Linux es considerado generalmente como la plataforma óptima. Moodle también se prueba regularmente con los sistemas operativos Windows XP/200/2003, Solaris 10 (Sparc y x64), Mac OS X y Netware 6.
  • Un servidor web. Primariamente Apache o IIS . No está completamente probado (o soportado) pero debería de funcionar con lightttpd, nginx, cherokee, zeus y LiteSpeed. Moodle se rehusará a instalarse en cualquier otro servidor web diferente a los descritos. Su servidor web debe de estar configurado correctamente para servir archivos PHP. La versión no es crítica pero se le recomienda instalar el paquete con la versión más reciente que tenga disponible.
  • PHP - La versión mínima es actualmente (enero 2013) la 5.3.2. Se requieren varias extensiones; vea la página de PHP para los detalles completos. La instalación de Moodle se detendrá durante la revisión del entorno si faltara alguna de las extensiones requeridas.
  • Una base de datos. MySQL y PostgreSQL son las bases de datos para desarrollo primario, las más completamente probadas y las que tienen abundante documentación y soporte. Oracle y MSSQL son completamente soportadas (tome nota de que los plugins opcionales pueden estar no probados con estas bases de datos) pero la documentación y ayuda en línea no son tan completas como con MySQL/PostgreSQL. Si tiene dudas, use MySQL (que tiene más documentación) o PostgreSQL (que tiene mejor estabilidad/desempeño). Usted necesitará las extensiones PHP apropiadas (configuradas si lo requieren) para su base de datos elegida.
    • MySQL - versión mínima 5.0.25
    • PostgreSQL - versión mínima 8.3
    • MSSQL - versión mínima 9.0
    • Oracle - versión mínima 10.2
    • SQLite - versión mínima 2.0
  • Navegador mínimo para accesar Moodle: Firefox 4, Internet Explorer 8, Safari 5, Google Chrome 11, Opera 9

Cliente

  • Sus clientes/usuarios accesan Moodle desde un navegador web en su PC/tableta/laptop. Cualquier navegador moderno sebería de funcionar (pero Internet Explorer 6 y anteriores NO están soportados). El sistema operativo no es importante pero Usted puede necesitar programas para leer los archivos que haya subido por ejemplo: Si sube archivos de texto de Microsoft Word, sus usuarios necesitarán un programa para poderlos leer).

 

PASOS RAPIDOS PARA INSTALAR MOODLE.

  1. Descarga la versión MoodleWindowsInstaller-latest-19.zip y descomprímela en el escritorio.
  2. Copia la carpeta de moodle en C
  3. Entra a la carpeta, verás tres ICONOS: Server, Start Moodle y Léame.
  4. Da doble clic en Start Moodle.
  5. Miniminiza la ventana de MSDOS (se abre al ejecutar el paso uno, NO LA CIERRES, PORQUE ES COMO CERAR LA PUERTA DEL SERVIDOR LOCAL).
  6. En el buscador, escribe: http://localhost
  7. Sigue las instrucciones, SÓLO DA SIGUIENTE --->
  8. No le asignes constraseña al MySQL, deja por defecto lo que se te presenta (no tiene contraseña, se encuentra en blanco el espacio, así déjalo; da clic en Siguiente.
  9. De preferencia deja el inglés, después puedes instalar el idioma.
  10. Activa el cuadro, actividad no atendida, no te preocupes, está en la parte superior central de la pantalla.
  11. Por último, dale nombre a tu sitio.